Sign in to my account Stay Connected! Sign up for the email newsletter

Rosetta Stone Browser Requirements

Rosetta Stone is committed to providing the most up-to-date and effective language solutions to schools and organizations. As we develop and update product offerings, we must focus our attention on developing resources that can help organizations meet their language learning goals in the most effective and targeted manner.

To that end, beginning in March 2017, we will no longer support browser versions older than Internet Explorer 11 or the latest versions of Chrome, Edge, Safari, and Firefox.

If you have questions about updating your browser, please first contact your IT team. If you have the ability to update your browser personally, the following resources are available to help: